Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Blog page missing H1

  • Hi great team!
    No hurries for this question, but my blog page does not have an H1 tag I see with a heading tag checker site.
    Apparently several other sites I’ve created also not.
    So I think I’m doing something wrong 😉
    What could be the issue?

    I thought about that I maybe disabled title within GP layout widget but that widget is not visible when I edit blog page.

  • Hello there,

    You may have disabled the page title for the Blog.

    What some web designers do is add a Block Element – Page Hero that has an H1.


  • Hi Fenrnando, thanks for reply. I thought also maybe I’ve disabled the page title but could not find the GP layout widget within the blog page. I’ve removed blog page from Dashboard, Settings, Reading. Than I could check and the title was not disabled. Also I could see the H1 tag in the source code.

    But now I’ve enabled the blog page as the blog page through Dashboard, Settings, Reading and I could not find the H1 tag.
    Do you have an idea what I can do now? I’ve also added H1 as a tag as Element (to the blog page) but nothing happened.

    I’ve added an admin account for you. Thanks in advance!

  • Hi there,

    if you use a Element to add the H1, can you make sure the Display Rules are set to the Blog ( which is listed at the top ) and not the static page you created.

  • Thank you David for the suggestion. I’ve tried that but than I then see the word “Blog” above all blog messages.
    But found that now, I’ve also had the hook set to before_content but had to of course select before_main_content 🙂

    Problem solved!

  • Glad to hear you got it resolved!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.