Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Blog Posts Query Update Issue

  • Hi,

    I noticed my blog posts are not displaying on my “Blog” page compared to my “Home” page. It seems that the information is not updating.

    If you see in the image below, this is my “Home” page, all the blog posts are showing.

    https://imgur.com/a/9F6Y43Y

    However, if you check the image below, this is my “Blog” page, it’s missing four blog posts.

    https://imgur.com/a/WT3ewl0

    I’m not sure if I’m missing some sort of setting or if it’s a glitch. Any help is greatly appreciated.

    Thank you,

    Marcus Ferguson

  • Hi there,

    Check the parameters of your query loop block on the Blog page. Have you set any offset parameters?

  • I don’t see an offset parameters option, so I don’t think so.

  • Have you resolved the issue?

    The blog posts on both pages use GB’s query loop block and show the same posts.

    Here is the home page: https://www.screencast.com/t/NiYGP48i
    And the blog page: https://www.screencast.com/t/5yDu8bGbjoRN

  • Hi Leo,

    Yeah it looks like it’s fixed. I’m not sure how, but it is.

    Thank you for the help!

  • It sounds like a caching issue to me.

    Make sure to clear any caching or optimization plugins if you are using any after every change.

  • It’s just weird to me that it updates on my home page, but not my blog page. I just had another blog posted today and it’s doing the same thing.

    But you’re right, after purging everything and preloading through my caching plugin, it shows up on my blog page!

    I’ll figure out how to get this fixed with them.

    Thank you again for the help!

  • No problem 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.