Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Centering Headline With Only 4 Words?

  • I have a paragraph I’m separating into two headlines. The reason is that I want the last line to always be on its own separate line to call more attention to it as the final idea and create more impact.

    I want both headlines centered so that all of the text is centered. The first headline is a very long sentence and has enough text to wrap to multiple lines. Centering it works just fine in this case.

    I duplicate this headline so the last line will use the exact same global style and settings. The duplicated text is of course looks exactly the same including the centering.

    I then replace the text in the second headline with the last single sentence which is only four words long. It’s not long enough to need to wrap to a second line and for some reason, the text centering stops working. It behaves as if I’ve chosen left align.

    I find this baffling and I don’t think that messing with spacing settings will work as well.

    Can someone help me understand what’s going on and suggest the best way to do this? Please ask if any of this is unclear. Thank you!

  • Hi there,

    Can you link me to the page where I can see the text?

    Let me know 🙂

  • please see private info section

  • The paragraph headline is set to display:flex, change it to default, and then you can use the text-align option to align it to center 🙂

  • Please look again. I’ve deleted all those unnecessary and I’m just using a headline now. Still, centering doesn’t work. Thanks!

  • the display is still set to flex, can you set it to default? The setting is in the layout panel.
    https://app.screencast.com/UPRsSsXmldmsx

    And then you can use the text-align option.

  • Please take a look at the private info again. You should see a link to a video.

    My understanding is that you’re saying to set the Headline block display setting to default. I see the image you posted showing that it looks as though the display setting is set to Flex. You’ll see in the video where I show you what I’m seeing in the interface. It certainly looks to me as though the headline display setting is set to default.

    Thank you for your help and patience, I’m just missing something and hopefully, the video will help you see where I’m going wrong here.

  • Please pay no attention to the headline of that video (which mentions something about “Soft Flex”)

    That service has AI automatically naming things and it just came up with an annoying name I can’t change

  • Hi there,

    that Headline ( in your video ) has a Global Style set to Quote Text – has the display flex been set there ?
    As note if it has, you can override it by setting the local blocks styles Display to something else eg. Block

  • Hi David

    “that Headline ( in your video ) has a Global Style set to Quote Text – has the display flex been set there ?”
    Yes, the Global Style was set to Flex. I was trying to change the Display setting to Default locally and that didn’t work. I guess I don’t understand what setting the Display setting to default locally actually does.

    So if you’re using a global style in this situation set to Flex, or Block or whatever other setting then setting the Display to default just inherits whatever is in the Global Style? That would make sense I guess but what does setting Display to default do if there is no Global Style?

    Anyway this does work now. I’m just tying to understand more so I don’t have to come back with questions like this. Thanks!

  • I was trying to change the Display setting to Default locally and that didn’t work.

    If you want to override the global style, you need to set it to block, setting it to default is equal to no setting, so it doesn’t work.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.