Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Changing “post date” to “date updated” in GP explore

  • Hi, I’m also having issues with every post showing the date published, rather than the date updated.
    I’ve tried every piece of additional CSS I can find, including this
    So far nothing works.
    I can see the single post here says “post date” there must be a way to change that maybe?
    Thanks, site link beloew.

  • Hi there,

    To display the updated date instead of the posted date, follow these steps:

    Go to Appearance > Elements and find an element titled Single Post Hero. Click on it to edit.

    Inside the Single Post Hero element, locate the post date headline block. Click on the floating setting bar and select the Dynamic setting.

    Under the Date Type option, choose Updated Date. You can also add a text before the date, such as ‘Updated on’, to make it clear that it is the updated date.

    For reference, please see the screenshot below:

  • Thank you, I’ve done that, it worked. Im not sure how to add the text “updated” there though. Thanks.

  • Now we have the correct dates on individual posts, but on the home page the “featured articles” still have the date published. Where do I fix that please? And it’s the same in all of the archives too. Thanks.

  • Hi there,

    If you’re referring to the screenshot I provided, under the Dynamic option setting, there is a Before Text field underneath the date type field. You just need to add the ‘updated’ text in that field.

    For the date on the featured articles on the homepage and archive pages, you can follow the same approach as the steps I provided for the single post date. For the featured article, you just need to edit the front page, and for the archive page, you need to edit the elements called Archive Cards in Appearance > Elements.

    Let me know if you have any questions.

  • Yes I have questions!
    I already tried to fix this via Elements > Archive Card.
    On this element all I see is 10 posts, the 10 that are appearing as “recent posts” on the front page.
    I can manually change each dynamic date on each entry to “date updated” but will that fix it for the other 800 or so posts on the site, as seen in any archive, for instance, a category archive.
    Or are you saying there’s somewhere to fix them all?
    Yes, I can manually edit the front page, but there’s no dynamic option to change it to “date updated”, that would just be manually typing in a date (or removing the date, which would seem to be a better option).

  • I take it back, I’ve found where to change the dynamic data to “date updated” on the front page, but the problem persists in category archive pages.

  • Ahh sorry about that, I forgot to mention that for the Archive Card element dynamic settings, they are located in the Block settings on the right-hand side instead of the floating toolbar. You can change the date type there.

    Refer to this screenshot:

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.