Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Critical error after customization

  • Hi,
    my webshop reached a critical error after the failed customization of a part on the sidebar.
    I want some help manually removing or correcting the part about the sidebar.
    There was probably an error when I started the Publish option after the change, but I guess the publish didn’t complete before I went to open a link in the WordPress admin section. After that, the page opens in the wrong mode (as if it is a display for a mobile phone or tablet and the sidebar does not load at all, but reports that it is a critical error.

    My web:

    And if I try to open Widgets from the Admin panel it can’t open. Also critical error message.

  • Hi there,

    Can you try disablling all your plugins first?

    If you can not access the site, please reach out to your host, they should be able to revert your site to a backup version.

  • Hi Ying,
    thank you for your fast reply.
    I use GeneratePress theme and GeneratePress premium plugin.
    Reverting to the backup version is my last option as there were new orders a few minutes before I made this problem. I would like to avoid that.
    I would be most happy if you could tell me where the widget settings are saved. Is it in some file or several of them or in the database?
    The problem is 99% in wrongly stored data about widgets in the sidebar because the first widget (search bar) is displayed correctly and after that, it says critical error.
    I tried switching the theme to the default theme Twenty Twenty-Four, but then I got an even bigger problem HTTP ERROR 500

  • Hi there,

    It should be in wp_options > sidebars_widgets.

    It’s best to backup your site before making changes in the database.

  • hmm, there is no such field in my database.
    I will make export of those new orders and restore to point at 4.2.2024.

  • I see. That’s odd. That would be a good idea.

    It’s also ideal to make a daily backup of your site. The more often backups you can take for your site, the better. This is a common practice for e-commerce sites for security as well.

  • Thank you Fernando, I know all that.
    But this was specific as I made changes just after the last order was made, so it wouldn’t even be able to restore the backup, since it was just before the problem

  • I see. In the database, it should look something like this:

    If you’re not seeing that, try locating an option with a name that includes widgets.

  • I restored everything from the backup and now I see that these records exist. Now, since I haven’t used phpmyadmin for a long time, I didn’t even open the contents of the options table this morning, only the list of tables, so maybe I could have done better if I had corrected those shortcomings. Basically, it was a problem with the database (I believe), because when I went to customization this morning, widgets/right sidebar was not on the list among the others, but only the top bar, so the others were missing. It probably didn’t save properly when I did the modifications yesterday. I’ve sorted out that part now, but I’m having problems with orders because woocommerce doesn’t connect new entries with old ones, but that’s another problem.

  • I see. Glad you’ve resolved the issue. It would be best to reach out to WooCommerce regarding that new issue.

  • Today I tried to change one block and I got this error:
    The editor has encountered an unexpected error.
    I have copied error but not sure if I would copy it here.

  • In what way did you change it? Are you changing the code? What sort of Block is this as well?

  • Hi Fernando,
    I didn’t manage to change anything. I went to open the block that I needed to edit (it’s a shortcode block that uses the Progress bar plugin) only two numbers, but as soon as I opened the editing of that block after a few seconds this error appeared.

  • I see. There’s nothing in GP/GB that should cause such an issue.

    Do you encounter this issue with the Progress bar plugin shortcode only and not other Blocks? If so, it’s best to reach out to their support regarding this.

  • it’s hard to tell because I have many widgets in that right tab

  • You’ll need to debug it then. I would recommend starting a staging/testing site, and then removing/re-adding the widgets along with disabling/re-enabling plugins as well to identify what’s causing the issue.

    If you can check your error logs as well, that would be good too in case an error was logged there that relates to this.

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.