Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Featured Image option disappears when using GP Child Theme

  • Hello,

    I searched the forum for similar topics and found some, I tried every solution given, but nothing seems to work and my issue is a bit different.

    The Featured image bloc is not here anymore, but only on GP handled pages.
    On WP pages not handled by GP, the option is still here.

    I have a GP child theme with some functions in it, I tried deactivating it and activating GP theme, and the option is back.
    So I’m sure there’s a problem with my child theme, but I can’t figure out what. It’s not a plugin-related problem since I tried deactivating them, it still doesn’t work when my child theme is activated.

    Please let me know if you want to take a look at my child theme.

  • Hi there,

    can you check in the Dasboard > Tools > Site Health, any issue showing there when the child theme is active ?

  • Hi David,

    Only that I should use persistent cache, that’s the only ‘recommendation’ showing.

  • OK, so i assume something in the child theme is messing things up.
    If you can share an admin login that will allow us to see the Appeearance > Theme Editor we can take a look.

  • Thanks David! I really don’t understand because I didn’t touch the website for a few days (it was finished…) and then suddenly today this problem comes up.

  • Hmmm… nothing really stands out as being an issue. Although whilst in the Editor > options ( 3 dot men ) -> Preferences -> Panels i can’t see the toggle for Featured Image

    Can you comment out each function in the child theme to see if one specifically is affecting this ?

  • I can’t see it either… And I already removed the function.php file entirely and the issue was still here.

  • Does the issue occur if you download and install a fresh child theme from here?
    https://docs.generatepress.com/article/using-child-theme/

  • I just tried it: now it doesn’t occur when the functions.php file is empty, but as soon as I update it with only one function, it disappears again.

  • – And the issue is fixed when you remove that one function?

    – Does this happen to any functions or this specific functions?

    – Are all other plugins disabled during testing?

    – The featured image feature is a WP core feature so does the same issue occur when using a Twenty series WP theme?

    We haven’t received any other reports on this so I would guess that it’s something specific to your install.
    You will need to strip everything clean and down to the very basic to identify the problem.

  • Thanks Leo. I added the functions one by one, and finally figured out something ‘wrong’ (not even sure it is, but it solved my problem) in my ‘register_taxonomy’ functions.

    Very specific to my case, but I’ll still explain it here, so it doesn’t happen to someone else.

    I created a custom post type via CPT UI plugin, and wanted to assign it some taxonomies (register_taxonomy function).
    I added them directly into function generatepress_child_init(), where I had added some custom taxonomies for WP ‘classic’ posts as well.
    But after some research I figured maybe I couldn’t do that because posts and custom posts aren’t really the same.
    So I deleted the register_taxonomy functions for my custom post type, and created their custom taxonomies directly via CPT UI.

    Now it works.

    Second lead
    In French, ‘Featured image’ is “Image mise en avant”. And I happen to had named two of my custom taxonomies “Articles en avant” and “En avant”. I changed it just in case, it didn’t work, but it was before deleting the CPT taxonomies from function generatepress_child_init(), so I can’t really know if it had something to do with my issue.

    Anyway it’s solved, but I still don’t understand why, before reinstalling a fresh child theme, the issue was still here even with an empty functions.php file. With cache emptied, plugins deactivated, etc.

    Let’s hope it still works in a couple of days 🙂

    Thank you Leo & David!!

  • Glad to hear 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.