Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Full Page Hero Not Working on all Pages

  • I imported a site library for my website which had a full page hero for most of the pages.(Plumber)
    When I created a new page, I could not get the full page to display, only the contained version.
    I duplicated one of the pages from the site import, and modified it, and the full page hero is there. I have compared the pages, and been through all of the settings, but I do not understand why I cannot get the full page on a newly created page.
    What am I doing wrong?

    Plumber front page on my site where I copied in my hero block: https://www.deezunkerphotography.com/home-2/
    This page was the original imported page, but I added my hero block to see if the issue was a block or a page setting. It looks like a page setting issue.

    Front page design where full page does NOT work: https://www.deezunkerphotography.com/houston-commercial-architectural-photographer-2/
    For this page I was modifying my original front page, but I could not get the full page option to work. I also attempted to create a new page, but also had the same issues. The only way I could get my front page to work, was to duplicate the plumber front page, then paste in the blocks that I needed. This how I created to current front page of my site.

    Any insight is appreciated.

  • Hi there,

    edit the problem page, and in the layout meta box in the page settings side bar, set the Content Container to Full Width – see here:

    https://docs.generatepress.com/article/content-container/

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.