Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

GP “site-library” shows blank page

  • Hi there,
    I activated “site-library” after installing GP Premium.
    However, it shows a blank page.

    GeneratePressVersion: 3.4.0
    GP Premium Version 2.4.1

    Any ideas?

  • Hi there,

    Please check this article:

    And try going to “Settings > Permalinks” and clicking the Save button. This can sometimes kickstart WordPress to start recognizing the REST API as it should. Now go into the Library to see if the sites are loading.

  • Hi there,

    There is no “Refresh Sites button” on the blank page.
    However, I can click “site-library” on the right top of the page after activate GP premium.
    It just shows a blank page.

    I also tried. “Settings > Permalinks” and clicking the Save button.
    it doesn’t work on my side.

  • Can you provide an admin login for us to check?

  • thanks for your support.

    I cleaned everything and reinstalled it.
    It works now.

  • Glad to hear that 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.