Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

How to remove default padding from .inside-header?

  • My header’s padding was set in Header Padding using customizer and was just fine for the past year…until I upgraded my site to the newest GP/GBPro versions today.

    Now my .inside-header class is stuck at padding: 20px 40px, even though I have Header Padding set in the Customizer as 0 for all sides.

    According to another site of mine, using Chrome – Inspect Elements, when header padding is set correctly, there should be an .inside-header class that overrides the .inside-header set by “main.css,” and is applied by each individual page’s stylesheet. (This site is running recent GP/GBPro, but not the newest versions.) This per-page .inside-header class doesn’t show up for any pages on the site that isn’t working correctly.

    I checked and I do have the Spacing module turned on in GeneratePress.

    Can someone tell me why the Header Padding isn’t working anymore? I even removed W3 Total Cache just to avoid any cache issues. Sample page that shows the 20px 40px padding on the header is in private info.

  • Hi there,

    That sounds strange.

    The header padding option has been there forever and we’ve never encountered any issues:
    https://docs.generatepress.com/article/header-padding/

    Can you confirm that the customizer settings are saved and not just in draft?

    Let me know 🙂

  • Definitely not in draft. I’ve been in and out of the customizer multiple times trying to fix it, so it’s been published and republished multiple times over the past few hours. 🙂

    I’ve uploaded a screenshot link into the private info so you can see I have the padding set to 0 all around, and it’s published.

  • Are you using a child theme by any chance? If so can you activate the parent theme to test?

  • I don’t think so…I don’t even know what that is. I’m just using Generate Press 3.4.0, plus the latest versions of GP Premium, GB, and GB Pro.

    At one point, I did remove all my additional CSS, but that didn’t make a difference.

  • Hi there,

    Would you be able to provide temporary login credentials for us to take a closer look?

  • Sure. Thank you for being willing to help!

    How do I do that? Just create a new user profile and put the login info in private information?

  • Hi there,

    thats correct, a new profile with a fake email address and just provide us the login URL, User Name and Password in the private info field.

  • I have created a new profile. Access info is in the private information. Hope you can figure this out! Thanks again for your help.

  • Could you change the role of that login to an Admin User ? Otherwise we can’t see the customizer or the other Amin areas that could be at fault.

  • Sorry – I wasn’t sure which to pick. It’s changed to admin.

  • That is so strange. I’ve played around for quite a bit but cannot identify the cause.

    Can you start a staging site for us to debug further?

    Thanks!

  • Sorry for the delay. My hosting company had some trouble getting the SSL working for the staging site, but it looks like it’s working now. Same login, new URL in private info.

    Thanks again…I appreciate your work very much! (Plus, it’s a relief to know that it’s not something I’m doing wrong…for a change! 🙂

  • Plus, it’s a relief to know that it’s not something I’m doing wrong…for a change!

    Spoke too soon 😉

    It turns out that there is a closing bracket ) missing for the Content Background color:
    https://www.screencast.com/t/4HIfSK3P

    Let me know if this helps 🙂

  • Oh my gosh! I don’t even know how that happened. I was changing some colors out yesterday, but I never wrote any code into those boxes – I was just clicking on the circles to choose colors. How weird!

    THANK YOU SO MUCH for tracking this down – I never would have found it!!! Very much appreciated!

  • No problem 🙂

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.