Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

I can import ‘shop’ from site library but can’t import ‘niche’

  • I have installed a new wordpress website using hostinger auto installer.
    I have disabled all plugins except gp premium.

    I am trying to use ‘niche’ theme for my website.
    However, when i try to import, the process is stuck at “Importing content” and the circle keeps spinning, no matter how long i keep it open.

    But I can import the ‘shop’ theme without problem.

    I have enabled debug but the log doesn’t give any error.

    I have also checked the php parameters as mentioned in the support document and all those seem fine. Please let me know how to proceed.

    I am attaching the credentials to my website for checking.

  • Hi there,

    Can I get permission to try importing the Niche site library on your site from my end?

  • sure, no problem. I have included the username and password in the private information.

    I also want to bring to your notice that I have been trying to create this topic since yesterday using chrome browser. But I couldn’t. As soon as i clicked on ‘Submit’, I just reverted back to default state. Nothing happened. Now I tried firefox and succeeded. Do you think I have cache issues in chrome or is it some kind of bug?

  • Okay, so I’ve tried to do the import and did not succeed either. Can you check your server’s settings to see if they match the recommended settings below?

    PHP max input variables 4000
    PHP time limit (max_input_time) 1200
    PHP memory limit 512M
    Max input time 600
    Upload max filesize 300M
    PHP post max size 512M

    Do you think I have cache issues in chrome or is it some kind of bug?

    I used Chrome as well but did not encounter this issue. Perhaps your browser extensions are interfering?

  • my settings are

    maxExecutionTime: 360
    maxInputTime: 600
    maxInputVars: 5000
    memoryLimit: 2048M
    postMaxSize: 2048M
    uploadMaxFilesize: 2048M

    attached screenshot
    php settings

  • Hi there,

    those settings are a little on the low side, especially for a Woocommerce site.
    Can you get the host to increase those values to at least the same level that Alvind provided here

  • Hello David,

    I am a layman when it comes to web development. I am trying to develop a website for my own business.
    But for a layman like me, I think the settings that I provided are actually higher than those provided by Alvind.

    1. PHP max input variables 4000
    2. PHP time limit (max_input_time) 1200
    3. PHP memory limit 512M
    4. Max input time 600
    5. Upload max filesize 300M
    6. PHP post max size 512M

    My settings (in the same order as Alvind)
    1. maxInputVars: 5000
    2. maxExecutionTime: 360 (this seems lower so i increased it to 1200)
    3. memoryLimit: 2048M
    4. maxInputTime: 600
    5. uploadMaxFilesize: 2048M
    6. postMaxSize: 2048M

    I hope i have matched these two lists properly. If anything else needs to be changed please let me know.

  • If you go to Dashboard > Tools > Site Health
    On the Info tab, check the Server settings.

    see here:

    Those two values need to be improved.
    I am not sure how you made those improvements above, but they may not have been carried through to the server. Can you check with your host to make sure they get applied ?

  • thanks for pointing out. I did not know how to check these from wordpress. Strange that the settings did not carry. Now I have made changes to the .htaccess file and now the settings are as expected.

    PHP max input variables 5000
    PHP time limit 1200
    PHP memory limit 2048M
    Max input time 600
    Upload max filesize 2048M
    PHP post max size 2048M

    This is what is shown in the site health now.

    Still I am facing same problem. Stuck at ‘Importing content’

  • Any server side security ?
    As i wonder if its getting blocked, as the Niche site does load some PHP via the GP Elements module.

  • I checked all settings related to security on my hosting panel and I don’t see any setting that might affect this.

    Can’t it generate some kind of error as to catch where the problem might be?

  • Hi

    Any more pointers on how can I proceed?
    Any way to check what could be the error?

  • Could you try the solution here if it applies to you? It’s quite a bit of work but might be worth a try:

    The user in the topic above also met the server requirements but still wasn’t able to import a particular library. I think this may be the same case as yours.

  • Hi Alvind,
    I have gone through the thread and what I understood was that the site was migrated from one hosting to another and the guy wanted to change the theme. When it did not work, he just exported all his data from the website and then reinstalled the wordpress.

    In my case I have not migrated. I am creating a new website and I have tried reinstalling wordpress many times. Also I don’t have any pages or any posts or any media or any plugins. There is nothing that can interfere. If it is a problem with rights, then I should not be able to import even ‘shop’ theme. The fact that I am able to import few themes but not others means there is something peculiar to those particular themes which is not sitting right with the installation.
    How can we get to know those things which are peculiar to those themes which I am unable to import.

    For example, I can install ‘search’, ‘freelance’, ‘realtor’, ‘shop’, ‘kicks’, ‘wander’. These are a few that I tried and can installed without problem. These also include ecommerce themes.

    But I can’t install ‘flavor’, ‘botanist’, ‘aroma’, ‘niche’.

    Any ideas?

  • Hello Alvind

    anything else that I can do to resolve it?

    is it possible for you to take a look at my hosting panel?
    I can share the login details if that is possible.

  • We’re currently investigating the issue and have already forwarded it to our dev team to take a closer look. We’ll keep this topic updated with any findings.

    is it possible for you to take a look at my hosting panel?

    Yes, if you’re okay with letting us check, that would be helpful as well.

Viewing 16 posts - 1 through 16 (of 24 total)
  • You must be logged in to reply to this topic.