Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Problems with subscriber form size

  • Hi team,

    How can I make the subscriber box stretch out – the design is normal but a page setting is making it scrunch up at the end.

    There is a headline block and shortcode block in the container.

    bunched up subscriber box

    Explore template from the site library.

  • Hi DLM,

    The Container Block for that section has a max-width of 1080px. Remove this and set the width to 100%.


  • This didn’t work, unfortunately. It didn’t change the size of the subscribe button and the ‘e’ is still dropped down.

    Any other ideas?

  • It’s still set to 1080px. See:

    Can you try changing it first? If you’ve changed it and it isn’t appearing, it must be caching.

  • I tried it a lot of different ways and it didn’t work – ie. changing both containers at separate times from 1080px to 100%. I tested both with ‘max width’ and ‘width’ but couldn’t get it to work.

    I had put it back to the original but have changed it again as you said so you can have a little look.

    Is it the purple bit in my screenshot that’s the problem and how do I change that setting?


  • I see. Can you provide admin login credentials? We’ll check you’re setup and see how to proceed with this.

  • Thanks, yes have added login details.

  • Can you change this one to 100%?:

    We’ll recheck afterward to see what happens.

  • Changed it and the button is still no good – you can see.

    I prefer the normal location of that container (not going off the edge) just want the short code to shuffle left a bit! 🙂

    Feel free to log in yourself and have a play around.

  • Hi there,


    1. Add this CSS to your site:

    .ml-embedded .ml-form-embedWrapper.embedForm {
        flex: 1;
        max-width: unset;

    This will make the form fill whatever space is available to it.

    2. then the shortcode block wrap it in its own GB Container Block.

    2.1. Then you can set the a Sizing > Max Width on that Container to control the forms size.

    And we can look at what to do for responsive controls afterwards

  • Thanks, I’ve added that CSS.

    It looks good on desktop and mobile but the button is still dropping down on tablet view. Also the break point from desktop to tablet is funny.

    I’m happy to give up and remove the section altogether if there’s no easy solution 🙂

  • Try to change the width of the Headline on Tablet and Mobile if needed. Example:

    Set it to a percentage value. Like 30% for Tablet and 100% on mobile.

  • Thanks – I’ve given this all a go but still have a problem with the breakpoint settings I think. When you shrink from desktop size to mobile the subscribe text drops down until you get to mobile.

    Please feel free to login and try things!

  • False alarm!

    It’s sorted now. Thanks a lot.

  • I see. You’re welcome!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.