Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Query loop post template container missing options

  • I’m trying to create a 3 column related posts section, and after finding

    https://generate.support/topic/generate-blocks-query-loop-column-number/

    I see that I have no options available for the post template block in my settings tab.

  • Hi Marcus,

    That’s odd. What versions of GenerateBlocks and GenerateBlock Pro are you using? Can you check if they are updated?

    If they are updated, can you try deleting the GB and GB Pro plugins? Then, re-download from scratch? It may be a bad install. Deleting GB and GB Pro and reinstalling them should be safe.

    It would be best to backup your site before doing this.

  • Blocks 1.8.2, Pro 1.6.0, running on wp 6.4.1

  • I see. That’s odd. Are you using any Site Library Template?

    Edit: Can you try testing on a different Browser first and Can you try #1 here to debug: https://docs.generatepress.com/article/debugging-tips/

    It’s recommended to backup your site before proceeding with this.

  • Redownloading and Reinstalling both plugins did not resolve the issue. I am using a gp pro child theme with a little custom css and php. However, switching to the unmodified parent does not resolve the issue either, nor does deactivating all other plugins.

  • Can you check the custom codes you have in your functions.php file? Check if you have codes there, and remove them one by one temporarily to see if any of them is causing the issue.

  • commenting out all custom code in functions.php does not resolve the issue

  • Hi there,

    if you create a new Query Loop on a draft page does the issue persist ?

  • Yes, the issue persists on a new draft page with all other plugins deactivated and on stock 2023 theme.

    New screenshots for your reference.

  • That’s odd, can you provide an admin login for us to check the backend?

    If you can create a staging site for us to do some more digging, it would be great!

    Thanks and let me know!

  • admin login created

    Also, this work (and the issue) is occurring on a staging version of the site.

  • The issue occurs due to there are no posts being published on the staging site.

    I published one post, and now it works.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.