Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Queryloop sort always using sticky settings

  • HappyUnderWater

    When using a Queryloop on a page to display all posts, I select all posts, then for additional parameters, I use Order By Date and Order DESC. In the page editor, the posts are shown in the correct order. But when I update the page, then refresh the correct page (not in the editor), sticky posts are at the top, followed by the remaining posts in date descending order.

    I would expect that since my Queryloop has no parameter for sticky posts, it would not use sticky in the ordering of the posts.

    Am I doing something wrong?

  • Hi there,

    That is the default behavior of sticky posts, whatever post you set to sticky will come up on top regardless of the order.

    If you want to exclude sticky posts, you just need to add the Exclude Sticky post parameter.

  • HappyUnderWater

    Got it! Adding a parameter for Sticky Posts and selecting Ignore did the trick. Selecting Exclude removed the sticky posts from the list.

    That solved my problem, but I still feel there is a bug because the order of the posts displayed while editing the page did not match what was displayed when I viewed the page live. When I added Sticky Posts Ignore, the order did not change in the editor, but it did when viewed live.

    So, the editor and live views do not match when using Queryloop, selecting all posts, and setting Order By Date. The editor view shows the order by date, but the live view will put sticky posts first.

  • ..but I still feel there is a bug because the order of the posts displayed while editing the page did not match what was displayed when I viewed the page live.

    That is to be expected since what you see in the editor is not always 100% accurate. Dynamic content is generated differently in the editor.

    Glad that your initial issue is resolved!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.