Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Sticky Section is jumpy on Scroll

  • Good day,

    I’ve been trying to solve this issue myself, but I’m at the point where I’d really appreciate some help. I’d like to make a container stick to the bottom of my screen on scroll, but as I continue to navigate and scroll down on the page, the container “jumps” in and out of the screen. It also disappears when I want to scroll up which is different to when ‘Float Mode’ is activated. When I scroll up and down long enough, it eventually “sticks.” Please advise.

    Here’s the URL link: https://philippoulaw.com/cyprus-tax-resident/

    Thanks in advance.
    Nadia

  • Hi there,

    You have this CSS:

    .ticss-8852e2c3 {
       bottom: 0 !important;
       width: 100% !important;
       z-index: 1000 !important;
       transition: none !important
    }

    Try removing the z-index property.

  • Hi Alvind, Thanks for the quick response. I made the edits as suggested, but it doesn’t appear to make a difference.

  • It seems like the property is still shown here:
    https://postimg.cc/3dTmgJLS

    Make sure you save the changes and clear any caches if you have any.

  • Thanks Alvind. I have cleared all caches a couple of times. Not sure if there’s something else I’m missing here.

  • I can see it stick to the bottom on scroll, can you try it in an incognito window?

  • Hi Ying, Thanks for your feedback. The problem is not that it doesn’t stick to the bottom, but rather that the behavior on scroll is not ‘smooth.’ It keeps moving/jumping in and out of the screen on scroll, even in incognito. I have also tested this on numerous screens and browsers.

  • Hi there,

    i am not really seeing the issue either.
    It does appear abruptly when you first scroll ie. there is no transition as it display prop goes from none to block
    But i see no scroll issues.
    Could you share a screen recording ?

  • Hi David,

    Thanks for trying to assist. Please see the recording of my screen.
    https://www.loom.com/share/7f0a308cd5db428fb63f7138a1355503?sid=36b095c7-e189-4c90-8172-f09a2c188ba2.

    I’m surprised that the issue appears to be visible only on my side or perhaps I’m just not articulating the problem properly…

  • Does it happen if you’re NOT logged in to the site ?

  • Unfortunately, yes. I have tested it amongst my team members (who aren’t logged into the site) a couple of times, on different browsers and screen sizes and cleared my cache, but it still happens.

  • I see the issue now.
    I assume you have a CDN or a cahce, as we were seeing a completely different sticky element that was hooked into your footer, whereas this inside your post content.

    How is the script being added to make the element sticky ? As its that script that is the issue.

  • Hi David, thank you for all your help so far. I’m not quite sure what you mean by ‘script’ as I’m new to web development/design and my terminology is not great. I have recorded another video for you so that you can see my settings of the sticky element. Perhaps it might help answer your question.

  • So you are using a plugin to make it sticky, the script (JavaScript) is added by the plugin.

    I would recommend reaching out to the plugin’s support for this issue.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.