Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Uncaught TypeError

  • I’ve got a problem with a site where product image of WooCommerce on a single product is not visible.
    With an older version of Woo it’s working but with a new version not anymore.
    I could track it down to a problem in the combination of two plug-ins, GP Premium and CardGate.
    At CardGate they don’t see any issues with their software. And indeed when I disable GP Premium the problem is solved. But also when I disable CardGate instead of GP Premium the problem is solved. Odd.

    When I use the inspect tool on the single product page I see this message at the console screen:

    Uncaught TypeError: Cannot read properties of undefined (reading 'defaults')
        at HTMLDocument.<anonymous> (checkout.min.js?ver=8.7.0:1:81)
        at j (jquery.min.js:2:26860)

    Could you please take a look into this? Thank you!

  • Hi there,

    first thing to check is for any GP Elements that may be interfering.
    Temporarily disable the Elements module ( or set all Elements status to draft ) to eliminate that as a conflict

  • You’re the best David. Indeed after disabling Elements module it worked. I looked through all the elements and found the culprit! Thank you!

  • Glad to hear that!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.