Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Uploaded local font not working as expected

  • somethingoffreedom


    I have uploaded Montserrat as a local font to use on my website, but for some reason when I select it as the ‘Body’ option in typography it doesn’t make the changes everywhere I would expect.

    When I try with another font I uploaded (or other fonts listed) it changes the font in all places, so it appears to be an issue either with the font Montserrat or potentially the way I have uploaded it.

    I have manually selected the font to show up in certain places (such as the home page) but still my blog posts and privacy policy don’t show the font in the body as I would expect.

    I have provided the link to the staging URL in private information if you are able to take a look and see why Montserrat is not showing up as the font in these sections despite being selected as the body text in typography.


  • Hi there,

    the homepage is displaying Montserrat but it is still making a google font request for it. Its not loading it locally.

    Could you disable the Ezoic optimiations and any other optimization / cache plugins so i can take a closer look at the source code ?

  • somethingoffreedom

    Hi David,

    Thank you for taking a look.

    I have disabled the Ezoic plugin, the Smush plugin and the OMGF plugin, which I think are the only relevant optimisation or caching plugins. Let me know if that helps!

    I have also put in the private information a temporary login link if you need to take a look at anything in the wp admin.


  • Ah ok, in Customizer > Additional CSS – delete this:

    			/* GeneratePress Site CSS */  /*  
     * End GeneratePress Site CSS */

    as a) its not needed and b) that extra * is invalid and breaking the CSS after it.

    That should load your local font correctly.

    Then go to Dashoard > GenerateBlocks > Settings and check the Disable Google Fonts option. As on your home page you have some block settings set to load the Montserrat font via google.

  • somethingoffreedom

    That’s brilliant, thank you for your help!

  • You’re welcome

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.