Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on WordPress.org (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

White space under footer

  • Hi guys,

    I decided to hide the copyright bar on my website as I display it somewhere else. I did that using the following css code I found on the forum:

    footer.site-info {
        display: none;
    }

    While the copyright content is gone now, there’s still white space (a bar) at the bottom of the website. See this image:

    https://imgur.com/a/M1Gs4by

    Strictly speaking, it’s not underneath the footer, but underneath an element I created and that I put below the footer (which contains some text and a link to the privacy policy). I selected “after_footer_widgets” under Hook Name. The background color of the element’s container is not white so I don’t think the element is responsible for this?

    Thank you for your help. Let me know if you need more info.

  • Hi there,

    Can you link me to your site where I can see this issue?

    Let me know 🙂

  • Hi Ying! The site is not live yet so that won’t be possible.

    See this image (footer + element under the footer, both have the same background color):

    https://imgur.com/a/U81H3ls

    The copyright module is not active (& I added the css mentioned in my previous post):

    https://imgur.com/a/kAHGW2K

    The element settings (only some padding left & right, I didn’t touch the rest):

    https://imgur.com/a/bMdLQ5Y
    https://imgur.com/a/rzxmL7j
    https://imgur.com/a/sBG4EOK
    https://imgur.com/a/Ve0pXJ1

    Let me know if you want me to share anything else that can help you identify the issue.

    Thanks!

  • Hi there,

    edit the Element you created, and make sure there is not an empty paragraph block at the bottom of the editor.
    If thats not the issue, can you share a screenshot of the element editor with the list view open.

  • Hi David,

    See the images below:

    https://imgur.com/a/XA4Kj1Q
    https://imgur.com/a/FVbaHOT

    There’s no empty paragraph block?

    Let me know if you need anything else.

  • I can’t tell from the screenshot, I will have to see the live site to know the issue, unfortunately.

  • Ok, no worries, I’ll put the site live next week or next month, will then share the link so you can have a look at it. Many thanks for the quick replies.

  • The Columns Block and the Paragraph blocks have built in Margins , which may be the issue.
    To test that, select the Container Block and give it a large Spacing > Padding Bottom value eg. 200px
    If the gap goes away then you know the above is true.

    For better control here, use a GB Grid Block instead of the core columns block, and GB Headline block instead of the Paragraph block. The GB blocks have full built in spacing controls.

  • That was indeed the issue. Solved now! Thanks a lot for the support.

  • You’re welcome

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.