Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

Why would you do this?

  • Hello. I am attempting to simply style some elements. However, every time I use the columns block I run into this bs:

    @media (min-width: 782px) {
    .wp-block-columns {
    flex-wrap: nowrap !important;

    Which is set as default from GeneratePress. Why would you do this? Now it is a fight trying to undo this every time I use a columns block.

    How can I undo what you’ve done?

  • Hi there,

    That CSS comes from the WordPress block library styles, it has nothing to do with GeneratePress and we have no control over that.

    We would recommend using the GenerateBlocks Grid Block or its Container and Flexbox options if you want greater control over the grid.

    Or if you must use columns and you want to overcome that CSS then you can add this CSS to it:

    @media (min-width: 782px) {
        body .wp-block-columns {
            flex-wrap: wrap !important;
  • Oh Ok. My mistake. Late nights and little progress makes a poor combo when asking for help. Thank you for clarifying.

  • No problen. Glad to be of help

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.