Are you a GenerateCustomer?

Do you have an active GP Premium or GenerateBlocks Pro license key?

Create a GenerateSupport account for GeneratePress and GenerateBlocks support in one dedicated place.

Create an account
Already have a GenerateSupport account? Login

Just browsing?

Feel free to browse the forums. Support for our free versions is provided on (GeneratePress, GenerateBlocks).

Want to become a premium user? Learn more below.

page hero as wide as the page

  • Hi, my homepage hero and my footer take all the width but my page is more compact/less wide. I would like my homepage hero and my footer to be as width as my page so everything is aligned on left et right onscreen. Help please?

  • Hi there,

    Are you using a Block Element for the Site Footer to build your footer? If so, edit that element and ensure that the outer container of the footer is set to Full Width.

  • yes I am using that. But I don’t want full width. I want the same width as my page. I sent you the link.

  • Sorry, I misread that.

    Edit the page and select the hero section. Under Sizing settings, set the MAX WIDTH to 1200px. Then, under Spacing, set the left and right margins to auto.

    You can do the same for the FAQ section. Remove the left and right padding to make it the same width as the other sections.

  • ok thanks. It’s better but a bit off. The Homepage Hero is too wide. I checked the padding and margin and cannot see why it’s not aligned with the page. Help please?

  • Select the inner container of the page hero and set the padding on the left and right to 20px

  • perfect! Thanks! Last alignemnent question: in my footer, the image of the two lines above is not aligned left and right with the borders of the container below. I checked everything and I cannot understand why. Help please?

  • The image itself has white spacing left and right, you need to crop the image in the media library, check the image (I hide your domain):

  • thanks

  • No Problem 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.